Creating Professional Weapon Skins in CS:GO


Published 03.02.2019 в 06:00 | Guide rating: 189



Introduction

                                                [color=#a94847]I DON'T[/color]                                        [color=#FFD700]PLAY[/color]                                          [color=#AFEEEE]CSGO[/color]                                      [color=#6c9541]ANYMORE, SORRY![/color]                          It sucks ;-; For a while, I looked on steam for a guide on how to make the cool looking custom skins like I see on the workshop but I never found one.
This is that guide.
This guide will focus on using Photoshop CS5 Extended to create professional looking weapon skins like you see on the workshop.
Like this.
Cinque Terre

Overview & Quick Guide

For those that know what to do and want to skip the details.
.
.
or if you want to see what you're up against.
Procedure: Download CS:GO Workbench Materials Open OBJ weapon file in Photoshop and load the respective texture on it Design your skin texture and save it as a TGA file Use VTFEdit to convert the TGA file to a VTF file Open the workbench in-game and apply the VTF texture Submit to the workshop (if you want)

Getting the Required Material

CS:GO uses what are known as Valve Texture Format (VTF) files for their weapon skin textures.
Photoshop cannot directly edit VTF files, so we need a different procedure.
But I'll explain that part in a bit.
WHAT YOU NEED IS.
.
.
Photoshop CS5 ExtendedIf you skipped the introduction, this guide requires that you have Photoshop CS5 Extended.
The standard version of CS5 cannot load the .
OBJ files which we'll be working with.
I'm not sure if other versions have the same 3D capabilities, but if they do, let me know.
If you don't have Photoshop, you can download a trial version from the Adobe website.
Workbench MaterialsYou're going to need the CS:GO Workbench Materials: Workshop Resources These are all the editable Object and Texture files we're going to design with.
Custom Paint Job TXT FileTo load your custom texture properly in the CS:GO workbench, you need this in a text file: Custom Paint Job Copy the example and paste it into a new text file.
Save it and name the text file whatever you want.
We'll have to make a few tweaks in this file later.
VTFEditLastly, we need a program called VTFEdit: VTFEdit[nemesis.
thewavelength.
net] Remember how I was talking about VTF files? This program will allow us to convert our texture files into VTF format for use in-game.

Getting Organized

Lets face it.
.
.
**** gets cluttered.
To reduce the amount of file searching, lets create a folder to organize all of our files.
Put all of your workbench material folders as well as the TXT file in this folder.
I put mine in a folder named "Guide" because.
.
.
I'm doing this for you.
It's recommended that you create a folder for each design you work on because you're going to end up with a lot of files if you're working on multiple weapons.
Cinque Terre

Designing

Here is where your creative genius comes in.
.
.
but I have to teach you how to use it.
Time to open up PhotoshopWhen you open up Photoshop, hopefully you're going to see a screen like this: If not, don't worry.
It might look like that once we get started.
Now, the first thing we need to do to get started is to open up an OBJ file from the OBJs folder.
I'm going to open up the Five-Seven just because.
.
.
Go to File > Open.
Then navigate to your OBJs folder and open a file of your choosing, or the one named "five-seven.
obj".
Then, you're going to get this beautiful thing called a 3D object.
WOAH! If you press "K", it will select the Rotate Tool which will allow you to move it around in 3D space.
Next, we need to load a texture.
Go to Window > 3D.
This will open up the 3D {Scene} tab in the panel to the right.
In this tab, you will see an item named "__PS_3D_Default".
Click on it.
Then click the icon next to "Diffuse" in the displayed options and select "Remove Texture" Then click the folder icon next to diffuse which is in the same place as before, then select "Load Texture".
Navigate to the UVSheets folder and select the texture for the weapon you are designing.
If it properly loads, you should get something like this: Next, click that same icon next to diffuse again and select "Open Texture".
This should open that texture in a new tab.
This is where you edit you will create your custom texture.
Editing any part of the texture well automatically save and display on your 3D model in the other tab.
Now, its up to you to figure out which parts of the texture are which parts on the model.
I recommend creating a new layer for your pattern so that you can see the boundaries between the textures.
You can also use the magic wand tool to select the black parts in between the different parts, then go to Select > Inverse.
This will select only the parts so that you cannot mess up the boundaries.
Once you are finished, save your texture as a TGA file with the extension .
tga.
Cinque TerreCinque TerreCinque TerreCinque TerreCinque TerreCinque TerreCinque Terre

Previewing In-game

Now we need to convert the TGA texture file into a VTF file.
Open up VTFEdit, then go to File > Import.
Select the TGA file you used as your texture.
The texture should show up in the window.
Now, export this texture to whatever location as a VTF file.
We now have the usable texture for the weapon, but there is one last thing we need to do for it to work properly.
Remember that txt file?Open it and replace "bullet_rain_m4", replace it with the file path of your VTF texture file like "C:/Users/Whatever".
Make sure you have the quotation marks in there.
Now we can finally see it in game! Load up CS:GO and open up the console by pressing the key to the left of the "1" key.
If this does not open the console, go to your options and change it to make sure the console is enabled.
Then type in "workshop_workbench" in the console.
It should open up the worbench which looks like this.
.
.
See where it says "none"? Click on it and choose "Custom Paint Job" from the drop-down menu.
Then click the button right underneath that, navigate to the VTF file that you created for your texture and select it.
It will show up all messed up on the default AK47, so choose the Five-Seven.
Now, in the bottom right corner, click on "Load".
Navigate to your txt file and select it.
Your texture should now show up like you intended.
However, for some weapons, some textures show as default textures.
For example: the barrel and scope on the AWP uses default textures and so your designs for those specific parts will not show.
Cinque TerreCinque TerreCinque TerreCinque Terre

Submitting

Finally, the final stretch.
This is where you become rich and famous (assuming you've just made the greatest design in the world).
Click "Submit" in the bottom right corner.
A submission window should pop up like this.
.
.
This is where you fill out all the information for your weapon and submit the files.
Look where it says "Source Image".
This supposed to be the TGA file for the texture you created.
Read and Accept the agreement and click publish.
And you're done, buddy! Cinque Terre

Conclusion

There is no conclusion hahahaha!Now, go make some more cool designs!

Check out ma mixtape mayne

Its not exactly a mixtape, but you should totally check out my designs:Workshop Cinque TerreCinque TerreCinque TerreCinque Terre